Shopify Admin dgraded performance

Incident Report for talkpoint

Resolved

This incident has been resolved.
Posted Sep 15, 2026 - 14:50 CEST

Identified

Identified - We've identified the problem Admin and POS logins, and we're working on a solution.
Sep 15, 2026 - 07:00 EDT
Posted Sep 15, 2026 - 13:16 CEST

Investigating

Update - We have noted some recovery upon canceling and restarting the login flow. We continue to investigate and will keep you updated.
Sep 15, 2026 - 06:07 EDT
Investigating - Shopify Admins may be inaccessible to some merchants. We are currently investigating and will update you as soon as possible.
Sep 15, 2026 - 05:49 EDT
Posted Sep 15, 2026 - 12:57 CEST
This incident affected: Externe Dienste (Shopify Admin).